abgebrochener Auftrag und SQL Fehler

Hier können Sie Programmfehler in ALF-BanCo 7 melden

abgebrochener Auftrag und SQL Fehler

Beitragvon FFF » Do 25. Okt 2018, 17:04

neuer Auftrag erfaßt, senden, aus Versehen an die Tastatur gekommen, so daß das Flickercodefenster sich schloß, im TAN Dialog auf Abbrechen (NB, wäre geschickt, wenn man HIER den Flicker erneut aufrufen könnte!)
Meldung, daß der Auftrag noch in der Liste sei.
Auftragslisten geöffnet, ein Auftrag sichtbar, auf "Senden" -> "Es gibt keine Aufträge, die gesendet werden können" (!), in meiner Not etwas rumgeklickt, auf Freigeben ->
Auftragsfehler.PNG
Auftragsfehler.PNG (10.91 KiB) 612-mal betrachtet


Alf beendet, neu gestartet, Auftragsliste, Freigeben, Senden -> alles ok.

Das war seit sehr langer Zeit das erste Mal, daß ich einen Fehler (7.4.4 Business@ W8.1/64) habe, aber da ist noch ein Wurm versteckt...

PS: ""Es gibt keine Aufträge, die gesendet werden können" - wenn das heißen soll, daß die Aufträge die in der Liste sichtbar, aber wg. Fehlerstatus "gesperrt" sind, dann ist es IMHO eher unglücklich formuliert ;)
FFF
 
Beiträge: 299
Registriert: So 6. Dez 2015, 13:24

Re: abgebrochener Auftrag und SQL Fehler

Beitragvon ALF » Fr 26. Okt 2018, 08:45

Hallo,

danke für die Hinweise.
Wir werden prüfen, ob wir dies bei uns nachvollziehen können.

Gruß,
ALF
Benutzeravatar
ALF
Site Admin
 
Beiträge: 8232
Registriert: Do 9. Okt 2003, 14:21
Wohnort: Leingarten

Re: abgebrochener Auftrag und SQL Fehler

Beitragvon FFF » Di 26. Feb 2019, 14:20

ALF hat geschrieben:Hallo,

danke für die Hinweise.
Wir werden prüfen, ob wir dies bei uns nachvollziehen können.

Gruß,
ALF
Soeben aus der Vorlagenverwaltung heraus eine neue Rechnung überwiesen, anscheinend habe ich mich bei der TAN vertippt, weil "Fehler, falsche TAN eingegeben" -> Auftragsliste, "Senden"-> keine versendbarer Auftrag... -> "Freigeben" -> "Senden" -> "Parallelitätsverletzung.
Der Auftrag ist nach wie vor in der Liste, vorne mit dem "offenene Schloß". "Senden" -keine versendbarer Auftrag... -> nun gibt es aber keinen Freigeben Button mehr, sondern "Sperren" (!).
Klick auf Sperren bringt erneut die SQL-Fehlermeldung, diese weggeklickt, ist der Sperrbutton wieder zum "Freigeben" geworden (und das SchloßIcon im Auftrag wieder geschlossen). "Freigeben" -> SQL meckert wieder.

Per "Mehr" -> markierte Aufträge senden kriege ich wieder den Fehler und unmittelbar danach "kein versendbarer Auftrag".

Aus dieser Schleife scheint man nur durch Doppelklick auf den Auftrag, so das die Ansicht wechselt zum "Einzelauftrag", zu kommen - hier neben dem Formular auf Senden geklickt, funktioniert problemlos (obwohl zuletzt in der Liste der Auftrag noch gesperrt angezeigt worden war).

Dieses Problem scheint also auch unter 7.4.5 noch nicht ganz gelöst zu sein ;).
FFF
 
Beiträge: 299
Registriert: So 6. Dez 2015, 13:24


Zurück zu Fehler in ALF-BanCo 7

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste