Suchfunktion immer noch nicht zuverlässig

Hier können Sie Programmfehler in ALF-BanCo 8 melden
Antworten
Pflichtfeld
Beiträge: 223
Registriert: Do 1. Sep 2011, 15:32

Suchfunktion immer noch nicht zuverlässig

Beitrag von Pflichtfeld »

Moin,
2016 habe ich das erste mal auf diesen Mangel der Suchfunktion im Verwendungszweck hingewiesen, greife das aber nochmal auf:
Ich hatte eine Überweisung erstellt mit Verwendungszweck:
"Cites-Bescheinigungen 24 Schröten"
Das steht bei Alf im Vwz drin:
AlfSuche.jpg
AlfSuche.jpg (19.23 KiB) 1807 mal betrachtet
Die Suche findet weder 'Cites' noch 'Bescheinigung' noch 'Schröten'
Ich empfinde das als extrem lästig. Man sucht, denkt: Das hast Du doch überwiesen? oder will wissen, was das seinerzeit gekostet hat und findet diese Überweisung praktisch nicht.
Ist das wirklich nicht zu ändern?
Benutzeravatar
ALF
Site Admin
Beiträge: 12042
Registriert: Do 9. Okt 2003, 14:21
Wohnort: Leingarten

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von ALF »

Hallo,

vermutlich übermittelt Ihre Bank die Umsätze noch im alten MT940-Format.
Dort ist eine Verwendungszweck-Zeile maximal 27 Zeichen lang und der Verwendungszweck wird deshalb leider oft mehrfach getrennt.

Vermutlich deshalb ist in "CI TES" und "BESC HEINIGUNGEN" jeweils ein Leerzeichen bzw. eine Trennung drin.

Und vermutlich auch deshalb fehlt der Umlaut in "SCHRÖTEN".

Die Banken stellen nach und nach auf den CAMT-Abruf um, der die Daten so übermittelt wie diese per SEPA-Überweisung eingegeben wurden.

Dann sollten die Wörter nicht mehr getrennt werden und Umlaute sollten auch vorhanden sein.

Eine Möglichkeit bis dahin wäre es vielleicht, wenn wir zukünftig eine Option anbieten würden, dass "Leerzeichen bei der Suche nicht berücksichtigt werden".
Dann würde er "CI TES" und "BESC HEINIGUNGEN" finden.
Das fehlende "Ö" zu finden ist aber damit leider auch nicht möglich.

Wäre solch eine Option für Sie hilfreich?
Freundliche Grüße,
Ihr ALF-BanCo Team
Joachim
Beiträge: 289
Registriert: So 2. Apr 2006, 14:52
Wohnort: Niedersachsen

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von Joachim »

ALF hat geschrieben: Mo 22. Mai 2023, 08:53 Eine Möglichkeit bis dahin wäre es vielleicht, wenn wir zukünftig eine Option anbieten würden, dass "Leerzeichen bei der Suche nicht berücksichtigt werden".
Warum eine weitere Option? Die Problematik, dass bei MT940 mehrere Teilstrings geliefert, aber weder bzgl. der Suche noch der Darstellung verkettet werden schmort in AB schon länger. Meine Präferenz wäre, es einfach bzgl. der Verkettung mal zu versuchen.

In der Datenbank blieben alle gelieferten "Trümmer" einfach erhalten, lediglich die Darstellung und Suche verkettet alles.
Dann würden auch historische Umsätze davon profitieren und wir müssten nicht auf die volständige CAMT-Umstellung der Banken warten, frei nach dem Motto: "Und wenn sie nicht gestorben sind, fragmentieren sie die Daten heute noch". :wink:
Benutzeravatar
ALF
Site Admin
Beiträge: 12042
Registriert: Do 9. Okt 2003, 14:21
Wohnort: Leingarten

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von ALF »

Hallo,

das Problem ist, dass an der Trennung oft auch Texte stehen, die nicht direkt verkettet werden sollten.
Wenn wir diese einfach ohne Trennzeichen zusammenfügen würden, dann wäre der Text vermutlich genauso oft "unsinnig" und auch nicht besser lesbar.

Wenn z. B. dies in den VWZ-Zeilen steht
"Überweisung"
"Rechnung vom 17.3. für"
"Bestellung vom"
"10.3."

Dann würde daraus
"ÜberweisungRechnung vom 17.3. fürBestellung vom10.3."

Wir können leider nicht erkennen, wo dem Zusammefügen eine Trennung sinnvoll ist und wo nicht.

Hier hilft aus unserer Sicht nur, wenn die Bank die Texte so übermittelt, wie diese sein sollten - z. B.. im CAMT-Format.
Freundliche Grüße,
Ihr ALF-BanCo Team
Joachim
Beiträge: 289
Registriert: So 2. Apr 2006, 14:52
Wohnort: Niedersachsen

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von Joachim »

Hallo,
ja die Banken sind "blöd" bzgl. der Nutzung des MT940-Formats. Darin können wir sie aber nicht beeinflussen.

Der engagierte Softi sollte dazu aber etwas in der "Handtasche" haben und die Herausforderung annehmen.
Falls das Format MT940 ist (sofern man das in der DB unterscheiden kann oder muss), könnte man für die Suche die Einzelstrings ohne künstliches Leerzeichen verketten und mit einem "enthält" zum Erfolg führen. Und das mit einfachsten Funktionen wie strcat() und strstr().
Es ist mir auch schon mehrfach passiert, dass ich bestimmte Umsätze nur sehr mühsam wiederfinden konnte.
Eine Leerzeichen-resistente Suchfunktion selbst zu schreiben ginge auch, aber wozu denn.

Dann könnte man mit der "vergurkten" Ansicht des Verwendungszwecks leben, aber das müssen wir ja jetzt auch.
Wobei ich die Lage dabei nicht als aussichtslos einschätze und vielleicht sind gelegentlich verbundene Strings besser als dumme künstliche Leerzeichen.
Pflichtfeld
Beiträge: 223
Registriert: Do 1. Sep 2011, 15:32

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von Pflichtfeld »

ALF hat geschrieben: Mo 22. Mai 2023, 08:53 vermutlich übermittelt Ihre Bank die Umsätze noch im alten MT940-Format.
Dort ist eine Verwendungszweck-Zeile maximal 27 Zeichen lang und der Verwendungszweck wird deshalb leider oft mehrfach getrennt.

Die Banken stellen nach und nach auf den CAMT-Abruf um, der die Daten so übermittelt wie diese per SEPA-Überweisung eingegeben wurden.

Wäre solch eine Option für Sie hilfreich?
Ihre vorgeschlagene Option ist nicht hilfreich.
Vorschlag: Der in Ihrer Software eingegebene Verwendungszweck kommt in ein eigenes (evtl. neu zu erstellendes Feld) in Ihrer Datenbank.
Dieses Feld enthält genau das, was der user eingegeben hat. Sie haben dann eben zwei Verwendungszweck-Felder in der db, (eines mit der Originaleingabe des users, eines, welches die Bank zurückmeldet.) dürfte aber nicht viel ausmachen vom Platz her.
Die Suche könnte dann auf dieses Feld (oder optional auf beide oder auf das andere...) angewendet werden.
Joachim
Beiträge: 289
Registriert: So 2. Apr 2006, 14:52
Wohnort: Niedersachsen

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von Joachim »

Ich habe nochmal in den Sendeprotokollen (Abruf) nachgesehen. Darin ersehe ich zweierlei:

1. Leerzeichen "...G mbH..."
2023-05-22_171608.png
2023-05-22_171608.png (1.41 KiB) 1729 mal betrachtet
Hier steht im Log-File:
...
31DE16700202700654793018?32MONTANA Energieversorgung G?33mbH + Co
. KG
...
An der Stellen "?33" oder 25 oder ... wird oft ein Leerzeichen eingefügt, obwohl es offenbar nicht direkt übermittelt wird.
Das betrifft hier den Auftraggeber. Was bedeutet das bitte, ist das Original so oder nur eine Umcodierung im LOG-File?

2. Echte doppelte Leerzeichen
Ich habe auch eine Bank "erwischt", die bei den Auftraggebern ein echtes Leerzeichen zuviel liefert.
Dagegen kann AB natürlich nicht "anstinken".

Im Fall 1 könnte man doch eigentlich die ?-Sequenzen für die Suche und Anzeige ignorieren, oder?

Meine Postbank kocht auch noch mit MT-940, aber in mir kommt der Verdacht hoch, dass bei weiteren Banken noch allerlei verschiedene Süppchen gekocht werden, hmmm...
Benutzeravatar
ALF
Site Admin
Beiträge: 12042
Registriert: Do 9. Okt 2003, 14:21
Wohnort: Leingarten

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von ALF »

Hallo,

uns ist die Problematik prinzipiell bewusst.

Eine Lösung, die immer funktioniert, gibt es hier vermutlich leider nicht.

Wir würden aktuell doch dazu tendieren, am ehesten zukünftig eine Option anzubieten, mit der die Trennzeichen bei der Suche ignoriert werden.
Denn wenn wir diese generell ignorieren werden sicher einige Kunden plötzlich andere Suchergebnisse erhalten, mit denen diese nicht rechnen.

Über eine Option können die Kunden, die dies möchten dann die Suche anpassen.
Freundliche Grüße,
Ihr ALF-BanCo Team
Pflichtfeld
Beiträge: 223
Registriert: Do 1. Sep 2011, 15:32

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von Pflichtfeld »

ALF hat geschrieben: Di 23. Mai 2023, 09:04 Eine Lösung, die immer funktioniert, gibt es hier vermutlich leider nicht.
Doch: ein zweites Verwendungszweck-Feld, wie von mir angeregt.
Wir würden aktuell doch dazu tendieren, am ehesten zukünftig eine Option anzubieten, mit der die Trennzeichen bei der Suche ignoriert werden.
Besser als der Zustand jetzt.
Benutzeravatar
ALF
Site Admin
Beiträge: 12042
Registriert: Do 9. Okt 2003, 14:21
Wohnort: Leingarten

Re: Suchfunktion immer noch nicht zuverlässig

Beitrag von ALF »

Hallo,

danke für die Rückmeldung.
Wie Sie selbst geschrieben haben
"Die Suche könnte dann auf dieses Feld (oder optional auf beide oder auf das andere...) angewendet werden."
bräuchten wir auch hier eine Option, auf welches der Felder die Suche ausgeführt werden soll.

Diese Lösung würde außerdem nur bei in ALF-BanCo eingegebenen Zahlungen funktionieren.
In allen anderen Fällen (Lastschriften, Überweisungen von anderen usw.) wäre die Suche dann unverändert und würde solch getrennte Texte auch nicht finden.

Wir werden nochmal beide Lösungsmöglichkeiten intern diskutieren.
Freundliche Grüße,
Ihr ALF-BanCo Team
Antworten